Wanted: bad CDI's('89-'94)

Got questions? We got answers....

Wanted: bad CDI's('89-'94)

Postby cicone » 04:20 pm Dec 06 2004

Some of you are aware that I've been trying to build a CDI circuit from
scratch. I have a partially working model, but need to get the bugs out. Success here would be good for all of us. As you know, new CDI's run $200 or more---and they contain little more than a small circuit board and about $4 worth of electric components. If any of you have CONFIRMED bad CDI's from KDX200 model year 1989-1994, I would like to ask you to donate or sell them to me so I might reverse engineer this beast. The reason I need them is that some of the parts in my old one were destroyed in disassembly. Now that I've done it once, the next go will be much easier. I need to test certain of the components to find exact values. Thanking you in advance. Jay P.S.---of course I will share the results and offer assistance to those who wish to go the DYI route! :prayer:
cicone
Member
 
Posts: 78
Joined: 05:58 pm Nov 16 2004
Location: North Florida
Has thanked: 0 time
Been thanked: 0 time

Postby m0rie » 05:38 pm Dec 06 2004

Mine still works, but if it turns bad or I come across a bad one i'll make sure it heads your way. Any reason a 95-05 CDI wouldn't work as well?

-Maurice
1989 KDX 200
2007 TTR-50E
User avatar
m0rie
Supporting Member I
Supporting Member I
 
Posts: 2220
Joined: 10:25 pm Nov 29 2004
Location: Crescent City, CA
Has thanked: 0 time
Been thanked: 0 time

Postby cicone » 10:12 am Dec 07 2004

m0rie wrote:Mine still works, but if it turns bad or I come across a bad one i'll make sure it heads your way. Any reason a 95-05 CDI wouldn't work as well?

-Maurice


Hi Maurice! It might work, but Kawi has a different part number. Does anyone here know??? Oh, thanks for the support and happy holidays!
If anyone is interested and circuit board savvy, maybe you could help me identifiy a few components and their values. I can send a high res photo of the old board, modified schematic(thanks Jag), and illustration(thanks again, Jag).
cicone
Member
 
Posts: 78
Joined: 05:58 pm Nov 16 2004
Location: North Florida
Has thanked: 0 time
Been thanked: 0 time

Postby m0rie » 11:41 am Dec 07 2004

For some reason I thought CC was trying out a older 89-94 CDI on his KDX.
Send me a copy of them and i'll see if I can help you identify them.

-Maurice
1989 KDX 200
2007 TTR-50E
User avatar
m0rie
Supporting Member I
Supporting Member I
 
Posts: 2220
Joined: 10:25 pm Nov 29 2004
Location: Crescent City, CA
Has thanked: 0 time
Been thanked: 0 time

Postby cicone » 02:04 pm Dec 07 2004

Maurice, Did you get my PM?? Shoot me an email with your email address and I'll forward you the stuff. jay.cicone@raymondjames.com
cicone
Member
 
Posts: 78
Joined: 05:58 pm Nov 16 2004
Location: North Florida
Has thanked: 0 time
Been thanked: 0 time

Postby BJH » 01:06 pm Dec 26 2004

I don't have one available but I did find one on ebay while I was surfing around for stuff. I know this is not really what you are after but it's the best I can do.

http://cgi.ebay.com/ebaymotors/ws/eBayI ... eName=WDVW
________
Maine Marijuana Dispensaries
Last edited by BJH on 08:04 am Feb 17 2011, edited 1 time in total.
BJH
Supporting Member III
Supporting Member III
 
Posts: 80
Joined: 11:50 pm Dec 13 2004
Location: Western North Carolina
Has thanked: 0 time
Been thanked: 0 time

Postby cicone » 09:54 am Dec 27 2004

Hi Brad---Thanks for the thought. Just bought a used '94 CDI on ebay a couple weeks ago for $29.99 including shipping! Put it in yesterday and she's running like stink again. Now I can tear the old one back apart and make some changes to the circuitry. I will figure this out and pass it on!!
Happy holidays to all and thanks for the help. Still could use a bad CDI if anyone can get their hands on one.

Jay---in the saddle again! :mrgreen:
cicone
Member
 
Posts: 78
Joined: 05:58 pm Nov 16 2004
Location: North Florida
Has thanked: 0 time
Been thanked: 0 time

Postby johnnymotocros » 10:14 pm Jan 02 2005

Cicone, When my 98 220 started giving me problems, I managed to clean out the CDI PCB from the little black box. It took me a while, but I did it. I drawed the squematic from it and I still have the drawing. I could not find the part number on the small glass diodes ( look like zeners ) or in the big capacitor ( which reads about 1uf on my Fluke ), the rest I figure out.
I borrowed a CDI from a friend and that did not get my bike to start, same weak spark.
I could send you a copy of the drawing I made, just e-mail me a fax number. My CDI I`m planing to reuse it, once I find whats wrong with the bike. I`ll dip it on Epoxy if it works. I will get my son to macro a digital picture of the gutted CDI for you to see. E-mail me your e-address.
<<johnnymotocros@hotmail.com>>
johnnymotocros
Member
 
Posts: 12
Joined: 08:19 pm Jan 02 2005
Location: Puerto Rico
Has thanked: 0 time
Been thanked: 0 time

Postby cicone » 09:37 am Jan 03 2005

Hey Johnny---check my gallery for a photo of the cdi---everything I see tells me the little glass diode is a switching type around 50-100 millamps and 100v. I was told the large cap was 1.5uf 250v---let me know if you can confirm that false. The original SCR, which fails often, is a NEC 2amp(4amp/rms) 600v(if I remember). Think it's NEC part # 2P4M thyristor w/o heat sink(the large metal tab).
Jay
cicone
Member
 
Posts: 78
Joined: 05:58 pm Nov 16 2004
Location: North Florida
Has thanked: 0 time
Been thanked: 0 time


Return to KDX General Q&A

Who is online

Users browsing this forum: Majestic-12 [Bot] and 16 guests